One zone has decided to not like Alexa

  • 24 March 2019
  • 3 replies

Set up

Lounge room- echo dot- Sonos play bar and 2 play 3s (surrounds )

Kitchen- play 1 + play one (with Alexa, grouped as I cannot stereo pair as they are not the same model)

Bedroom 1 - echo dot + bose wave cd (plugged in through aux and set as default speaker with dot)

Bedroom 2- echo and play 1

Bedroom 3 - play 3

Problem- I purchased the play one a few weeks ago and I seem to have been trouble shooting since then. The currently problem is that in my lounge room I ask Alexa to play music and I am met with silence. I can ask Alexa to play music in any other room and it will play
I have deleted and reinstalled the skill several times and it does not work. I have deleted any playlists in Sonos app Incase that causes the issue as well and it
Has not done anything. I have also checked that software is up to date.

Could you please let me know what else I can possibly do?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Do you have any Alexa groups set up? If not, try setting up a Group in which the Bedroom 1 Echo is the Alexa device, the Play:1 is included in the device list, and the 'preferred speaker is the Play:1. Please post back.
John B, I already had them all set up. The only other thing that I did not say before is that my tv is plugged directly into the play bar.
Userlevel 7
Badge +20
Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser ( or>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)
1.4/ Here is a link to my naming standards:

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.