Answered

Language setting


We bought a Sonos One in France for use in our holiday house. I can’t find a way to make Alexa speak English. There is no language option in the app. How can I get the Sonos/Alexa to respond in English?
icon

Best answer by jgatie 26 July 2019, 16:31

Edit: It doesn't appear you can change the language via the Alexa app like you can an Echo. I'll keep looking.


Think I found it: Open the Sonos app on an Android or iOS device and select Settings>Room Settings, then select your Sonos One Room. Under Voice Services>login. You'll then see the Wake Word Language setting. Change this to English.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

Userlevel 1
Badge

Hi All,

Are you able to see Brazilian Portuguese available as a language on yours Sonos app language selection?

 

I can’t.

 

Regards,

Cesar

Userlevel 1
Badge

Open the Sonos App, go to Settings>Services>Amazon Alexa and then select your Alexa enabled Sonos device (Move/One/Beam).  Under the Voice Settings section, there is then the ability to change the Voice Language.

Hi jgatie,

 

Now Alexa supports Portuguese (Brazilian) but it doesn’t show up in the list you indicated for some reason in the Sonos app. I’m able to change it to different languages but not Portuguese, is the Sonos app missing an update maybe?

 

Tried to find a similar configuration for Language in the sonos web site but I couldn’t find it either, so I think the Sonos app will be the right location but Portuguese is not there.

 

Regards,

Cesar

Open the Sonos App, go to Settings>Services>Amazon Alexa and then select your Alexa enabled Sonos device (Move/One/Beam).  Under the Voice Settings section, there is then the ability to change the Voice Language.

Hello mine speaks italian and I don’t know what she is saying. I can’t find English! Alexa app devices doesn’t give language options. Pls help 

Hi jgatie - THANK YOU! Been looking for ages to try and change the language! You absolute star.
Userlevel 7
Badge +17
Fire up the Alexa app on your phone. Select Devices, then your Sonos device. Scroll down to Language, click on that and select the new language.
Hi we’ve got it back in action but Alexa is still speaking French and the options on our Sonos app don’t let provide for changing the language or the wake word.
Userlevel 7
Badge +20
Yeah it won’t even light up now. Don’t know what I’ve done to it.

Hi there,

Are you talking about the LED light on the speaker? If it's not lighting up, please double check that the power cable is fully inserted into the speaker, and that it is connected to a working power outlet. You might even try a different outlet to be sure. If you're still not getting any lights, please give us a call. Our phone team can take over troubleshooting from there.

With the speaker powered on, and connected to your router with an ethernet cable, there isn't much to stop your app from connecting. Make sure your controller is connected to the main wireless network created by the router, and go into the Sonos app. It will likely guide you through the initial setup process as you mentioned that you factory reset the speaker.
Yeah it won’t even light up now. Don’t know what I’ve done to it.
Ok I’ll try that and let you know a little later thx
As a note, factory resetting almost never solves anything, and it wipes out valuable diagnostic data.

But let's try to get you running. Temporarily wire the unit to your router with an Ethernet cable. Then try to add. After that, you can enter the WiFi credentials.
Those options weren’t showing up. So I tried a factory reset and now the Sonos won’t start at all. 😢
Edit: It doesn't appear you can change the language via the Alexa app like you can an Echo. I'll keep looking.


Think I found it: Open the Sonos app on an Android or iOS device and select Settings>Room Settings, then select your Sonos One Room. Under Voice Services>login. You'll then see the Wake Word Language setting. Change this to English.