Beam will not stop saying “Audio actions in routines are not supported on this device”


Badge
Hello fellow Sonosers. My new Beam is great, Alexa integration not so great, but hey, starving children in Africa and all that. I’m currently having a problem where I have deleted all the Audio Actions from all my Routines yet Alexa insists on saying “Audio actions in routines are not supported on this device” every.... single.... time. Does anyone know why it is doing this, especially after I have removed all the Audio Actions? Asking before I factory reset the Beam.

15 replies

Userlevel 6
Badge +21
Hi simplelife78

Stop! Do not pass Go! :cool: Seriously, do not do a factory reset of your Sonos. I suggest:

1. Unplug your Beam
2. log-out of the Alexa app
3. Disengage Alexa in the Sonos App.
4. Close the Sonos app.
5.Delete the Alexa app from your device(s) and re-install it.
6.Plug in your Beam and let it come back
7. Login to Alexa via it's app
8. Re-engage Alexa in Sonos.
9. Ask Alexa to discover devices

Let us know if this resolves the issue.

Cheers!
Badge
Thanks mate. I will try that and let you know if it worked..... on the weekend.... because that looks like a weekend job... with wine 😁
Userlevel 6
Badge +21
Great! That sounds like a party :cool: Now will that be red, white or maybe a nice rose'?

Cheers!
Badge
My impatience got the better of me. Alas, your kindly offered instructions did not work. Time for the factory reset.....or a hammer.
Userlevel 6
Badge +20
Hi

How did you get on?

The following list will resolve most issues, please test frequently as a factory reset is often not required nor the whole list of actions: :)

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.
Badge
I have tried everything, even a factory reset, and the Beam still insists on advising me that “Audio actions in routines are not available on this device”. Thanks to all for you assistance. I’m grateful for your efforts.
Userlevel 6
Badge +20
simplelife78 wrote:

I have tried everything, even a factory reset, and the Beam still insists on advising me that “Audio actions in routines are not available on this device”. Thanks to all for you assistance. I’m grateful for your efforts.



Okay just thought. Can you please open the Alexa App>Smart Home>Devices and Forget your Sonos Beam - This should delete the Beam from all Routines, if you've missed one. Now power down the Beam and then power up again. Please then open the Alexa App>Smart Home>Devices and select Add Device and add the Beam back into Alexa.

Please retest
Badge
Thank you to UKMedia and AjTrek1 for your prior assistance. Whilst unfortunately your kind advice was not successful, it was appreciated. I have narrowed this down to an issue with Alexa and not the Sonos Beam. I have however fixed the problem by completing the below:

I created a new Routine with a very different name. I had a Routine called "Alexa, Wake up" - The routine turned on a few Phillips Hue globes, which enabled us to stumble to the kitchen in our post sleep daze to make the coffees and not trip over a cat. But my new Beam kept announcing “Audio actions in routines are not available on this device” So I created a new Routine called "Alexa, Farting pickle" the new Routine turned on the same Hue globes as the previous "Alexa, Wake Up" Routine and the Beam stopped announcing “Audio actions in routines are not available on this device”. Very happy me.

However, when I Edited the name of the Routine back to "Alexa, Wake Up" the “Audio actions in routines are not available on this device” miraculously returned. After a brief scream of frustration I again edited the name of the Routine to "Alexa, Coffee Time" and Happy Days, the “Audio actions in routines are not available on this device” did not appear.

My problem is now solved... in part to a Farting Pickle :P
Userlevel 6
Badge +20
simplelife78 wrote:

Thank you to UKMedia and AjTrek1 for your prior assistance. Whilst unfortunately your kind advice was not successful, it was appreciated. I have narrowed this down to an issue with Alexa and not the Sonos Beam. I have however fixed the problem by completing the below:

I created a new Routine with a very different name. I had a Routine called "Alexa, Wake up" - The routine turned on a few Phillips Hue globes, which enabled us to stumble to the kitchen in our post sleep daze to make the coffees and not trip over a cat. But my new Beam kept announcing “Audio actions in routines are not available on this device” So I created a new Routine called "Alexa, Farting pickle" the new Routine turned on the same Hue globes as the previous "Alexa, Wake Up" Routine and the Beam stopped announcing “Audio actions in routines are not available on this device”. Very happy me.

However, when I Edited the name of the Routine back to "Alexa, Wake Up" the “Audio actions in routines are not available on this device” miraculously returned. After a brief scream of frustration I again edited the name of the Routine to "Alexa, Coffee Time" and Happy Days, the “Audio actions in routines are not available on this device” did not appear.

My problem is now solved... in part to a Farting Pickle :P



That made me laugh :)

I don't know why I didn't think of this before but I wonder if Alexa is thinking you want an Alarm set with your command. I don't have a Routine called Wake Up but if I ask 'Alexa, Wake Up' she replies 'What time would like the Alarm'.
Userlevel 1
Badge +1
I had the same problem which I narrowed down to a Philips light. This was a bit confusing. Why would a light tell me that audio actions are not supported.

It turned out to by a synchronization issue. Somehow it had an old light, before I renamed it, which it interpreted as an audio device.

The solution: "Alexa, discover my devices".

After that, all was good.
Userlevel 1
Badge +1
Forget what I said above. It was a short lived solution and the issue quickly came back.
Userlevel 6
Badge +20
Did you go through the steps I posted above?
Userlevel 1
Badge +1
Hi UKMedia,

At your suggestion, I followed your directions in a couple different ways.

Attempt #1
- Looked for duplicate device names - there were none.
- Logged into alexa.amazon.ca (Canada) and forgot all devices. Rediscovered devices.
- Opened the Alexa iPhone app, forgot Sonos, and re-linked Sonos.
- Looked at routines. I was expecting to have to setup routines again but they already existed.
- Tried a routine and receive the error: "audio actions and routines are not supported..."

Attempt #2
- Opened the Alexa app and deleted all routines.
- Logged into alexa.amazon.ca (Canada) and forgot all devices. Did not immediately rediscover devices.
- Opened the Alexa iPhone app, forgot Sonos, and forgot Hue.
- Re-linked Sonos and Hue.
- Re-discovered devices. This time only 15 devices were found. Previously, it was 17.
- Opened routines and now routines was empty.
- Realized that I forgot to re-add the Mysa skill so I did that. Two new devices were found for a total of 17.
- Re-setup the "good morning" routine using only the Mysa thermostat. Tested this. It worked!
- Added Hue lights to the "good morning" routine. I used the individual devices rather than the Hue rooms.
- Tested it with both Hue and Mysa "audio actions and routines are not supported..."
- Removed the Hue lights from the routine. Tested this. It worked again.

Somehow after all those steps, adding Hue lights into the routine causes the issue.
Userlevel 6
Badge +20
Hi Dan

Good that we know what device is causing the issue but confused as to why a Hue light is causing this.
Userlevel 1
Badge +1
UKMedia wrote:

Hi Dan

Good that we know what device is causing the issue but confused as to why a Hue light is causing this.



I'm confused as well but I continue to test:

1. Setup routing that included two thermostats (Mysa) and "All Hue lights (off)". It works!
2. Kept Mysa and "All Hue light (off)" and added "Hallway (on)". It works!
3. Kept Mysa and "All Hue light (off)", removed "Hallway (on)" and added "Bedroom light (on)". Error: "audio actions and routines are not supported...". I also tested this with the Bedroom (room instead of light) and it had the same issue.

The Mysa thermostat had no affect on the the issue. All Hue lights is the defaul group from the Hue app and Hallway is a room in the Hue app. I was not using any Alexa groups.

It's clear that ithe issue is limited to specific Hue devices. I'll continue testing to determine which devices work and which cause the issue and go from there.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings