Question

Alexa stops working until all Sonos devices powered off and on again.

  • 27 November 2018
  • 0 replies
  • 32 views

I've encountered this situation twice now in recent weeks, and it's very frustrating.

I have eight Sonos Ones, a Sub and a Playbar, covering four different rooms. Normally, everything works well, and the sound is impressive. However, once again yesterday I encountered a situation that Alexa would respond to the initial "wake" word, but then fail to provide any further interaction.

I tried using the Sonos Web Interface route to re-boot each of the eight Sonos Ones, but nothing improved. I rebooted my router, with no result. Looking at the history of my commands it seemed that nothing after the wake word was being detected. As an experiment I issued some commands without pausing after the "chime". In this scenario Alexa heard part of the command. It seems that some sort of time-out was occurring, after which the devices stopped listening for the full command.

I was able eventually to rectify the situation by going round individually to each Sonos device and turning it off. When they were all off I switched them on again, one by one. After this, Alexa worked perfectly. However, I don't believe it is acceptable that I have to do this each time - it is a time-consuming process, and many of the power-points are in difficult to access locations. Instructions elsewhere on this forum seem to recommend re-booting pretty much every Wifi-enabled device on the network, but in a home office scenario this would take me a considerable amount of time and result in unacceptable downtime.

Please sort this out, Sonos, I would expect better from you, after investing a considerable amount of money on these devices.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.