Alexa stop command not working on sonos my library

  • 19 September 2019
  • 8 replies

Until very recently i have been able to use the voice command 'alexa, stop music in the living room' when playing music from my library (off my NAS). All other commands such as resume, skip, volume up, etc all still work. The stop command still works for other streamng services such as radio and amazon music.

Tried alternate commands to stop such as pause, freeze, halt but nothing works

My system is a mixture of echo dots connecting to a zp100, play 1 and play 5. All used to work fine and now all have the same issue

I have tried disabling the sonos skill and then setting it back up again but no joy. Anyone else have the same issue or know what the fault is?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Hi all

all fixed now. An update by amazon released yesterday has fixed it. Thanks all for helping though
Try "Alexa, stop the music". I occasionally have to use it.
Userlevel 5
Badge +8
Try 'cancel' this is the only thing that works in our house, I hope they fix it soon!
Userlevel 7
Hi graham_51

You obviously had everything setup correctly at one time. Since you are not using any Sonos Alexa enabled devices I'd have to say the issue lies with Amazon Alexa.

However, there two more things you can try:
  1. Open your routers Admin page and check for updates. Install them if available and reboot your router.
  2. You can also submit a diagnostic within 10 minutes of the next occurrence and post the reference ID in this forum. Then call Sonos Tech Support or contact them via Twitter or Facebook.
I hope you get things sorted out.
Userlevel 7

Understood concerning 3 and 11. Your profile does not indicate what products you own so I thought I cover all possibilities ☺

Hi AjTrek1

Tried that (except steps 3 and 11 that i cant do on my setup) and no difference. Exactly as before.

Any other ideas?


Thanks for your response which i will try but 3 and 11 dont apply to my setup as i have play 1 and 5 (not integrated alexa) not sonos 1 and 5 (integrated alexa). If there is a setting for those points in the play devices then can you confirm where as i have never seen it or never used it before

Userlevel 7
Hi graham_51

This is a repeat of some of your steps but please follow them in order given:

  1. Unplug your Sonos
  2. Unplug your Alexa devices
  3. Sign out of Alexa voice in the Sonos app
  4. Delete the Sonos Skill in Alexa
  5. Sign out of Alexa account
  6. Reboot your router
  7. Power cycle your device
  8. Plug-in your Sonos 1x1 let each come back
  9. Sign into your Alexa account
  10. Enable the Sonos Skill
  11. Enable Alexa in the Sonos app
  12. Plug in your Alexa devices 1x1 let each come back
  13. Ask Alexa to discover devices
  14. Test your commands
Let us know how things sort out. Cheers!