Answered

Alexa, Sonos and Dojo by Bullguard

  • 12 February 2019
  • 6 replies
  • 131 views

Hi All, totally new to Sonos but got it all working without issues including Alexa integration. Then I added Dojo by Bullguard to my network for a bit of extra IoT security and now Alexa cant initiate music on my Sonos even though it thinks it has. I can get to Amazon Music source and radio direct in Sonos app but Alexa (even inbuilt) wont start any music sources. Other basic Alexa stuff like asking it questions works. Anyone else have a Dojo or have any ideas why this is happening?
icon

Best answer by Ken_Griffiths 12 February 2019, 11:51

Thanks Ken, they told me to come here! It's a pretty new device so they are not experienced with all the possible devices and amazingly I am the first with Alexa enabled Sonos 🙂. The Dojo app is limited in setup/user config to allow traffic etc but it's a WIP I guess.It reminds me of the old Yoggie Gatekeeper firewall devices where you could access the interface over a web browser rather than an App and unblock/block Apps, ports and such like with built in anti-virus. I would have thought checking the App to see what is blocked might help. I’m not sure if this helps, but I think Sonos requires the use of all the following ports:

TCP/IP:
* 80 (Internet Radio, updates and registration)
* 443 (Rhapsody, Napster, and SiriusXM)
* 445 (CIFS)
* 3400 (incoming UPnP events - Sonos Controller App for Mac or PC)
* 3401 (Sonos Controller App for iOS)
* 3445 (OS X File Sharing)
* 3500 (Sonos Controller App for Android)
* 4070 (Spotify incoming events)
* 4444 (Sonos update process)
UDP:
* 136-139 (NetBIOS)
* 1900 (UPnP events and device detection)
* 1901 (UPnP responses)
* 2869, 10243, 10280-10284 (Windows Media Player NSS)
* 5353 (Spotify Control)
* 6969 (Initial configuration)

Not sure exactly what Alexa requires ... but the first thing is perhaps to remove the Dojo and make sure it is that, that is causing the issue, then see if it somehow blocks the ports above in some way. Perhaps speak to Bullguard support again and see if they can advise further. They will surely want to find the answer to this in any event.

I would also perhaps dig around some more to see if you can see what ports the Amazon Alexa echo devices require access to.

Hope that helps (a little).?
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Don’t use it myself, but Bullguard have a customer support portal here for their Dojo device:

https://dojosupport.freshdesk.com/support/login

My guess is you need to look in the Dojo App to see what the Dojo device has blocked already and simply remove whatever is obviously related to Sonos and Alexa at this stage, but before doing that, it’s best to perhaps consult with the Bullguard Support Desk.
Thanks Ken, they told me to come here! It's a pretty new device so they are not experienced with all the possible devices and amazingly I am the first with Alexa enabled Sonos 🙂. The Dojo app is limited in setup/user config to allow traffic etc but it's a WIP I guess.
Thanks Ken, they told me to come here! It's a pretty new device so they are not experienced with all the possible devices and amazingly I am the first with Alexa enabled Sonos 🙂. The Dojo app is limited in setup/user config to allow traffic etc but it's a WIP I guess.It reminds me of the old Yoggie Gatekeeper firewall devices where you could access the interface over a web browser rather than an App and unblock/block Apps, ports and such like with built in anti-virus. I would have thought checking the App to see what is blocked might help. I’m not sure if this helps, but I think Sonos requires the use of all the following ports:

TCP/IP:
* 80 (Internet Radio, updates and registration)
* 443 (Rhapsody, Napster, and SiriusXM)
* 445 (CIFS)
* 3400 (incoming UPnP events - Sonos Controller App for Mac or PC)
* 3401 (Sonos Controller App for iOS)
* 3445 (OS X File Sharing)
* 3500 (Sonos Controller App for Android)
* 4070 (Spotify incoming events)
* 4444 (Sonos update process)
UDP:
* 136-139 (NetBIOS)
* 1900 (UPnP events and device detection)
* 1901 (UPnP responses)
* 2869, 10243, 10280-10284 (Windows Media Player NSS)
* 5353 (Spotify Control)
* 6969 (Initial configuration)

Not sure exactly what Alexa requires ... but the first thing is perhaps to remove the Dojo and make sure it is that, that is causing the issue, then see if it somehow blocks the ports above in some way. Perhaps speak to Bullguard support again and see if they can advise further. They will surely want to find the answer to this in any event.

I would also perhaps dig around some more to see if you can see what ports the Amazon Alexa echo devices require access to.

Hope that helps (a little).?
The majority of the ports in the above list are for local use only. The last thing one should do is simply open up a firewall for all of them. Only a few TCP ports relate to outbound internet traffic.

It appears that the Dojo's preferred configuration is as a replacement DHCP server, so that it can redirect all internet traffic through itself. In that case all the devices on the network would require a reboot following its installation.

(I also found a few references to ARP spoofing, which in theory should 'just work' without disabling the router's DHCP server, but in my experience this technique has some drawbacks as it basically hijacks the device traffic by using bogus ARP responses to perform a 'man-in-the-middle' interception.)
Thank you. It is a replacement DHCP server separating devices according to type. Dojo is keen on closing ports and blocking pings so I think it's something to do with the way Alexa requests queuing of music with Sonos.

Interestingly Alex works just fine on it's own and Sonos works fine on it's own, its just Alexa control of music on the Sonos that doesn't work. An echo device gets radio/Amazon music fine and the Sonos will play radio/amazon/any source if queued from the app.

Without the Dojo in the network this Alexa/Sonos functionality worked fineas wellnso its definitely a Dojo issue. I have rebooted everything on the network as well.
Thank you. It is a replacement DHCP server separating devices according to type. Dojo is keen on closing ports and blocking pings so I think it's something to do with the way Alexa requests queuing of music with Sonos.

Interestingly Alex works just fine on it's own and Sonos works fine on it's own, its just Alexa control of music on the Sonos that doesn't work. An echo device gets radio/Amazon music fine and the Sonos will play radio/amazon/any source if queued from the app.

Without the Dojo in the network this Alexa/Sonos functionality worked fineas wellnso its definitely a Dojo issue. I have rebooted everything on the network as well.
Did you try removing/reinstalling the Sonos Skill in the Alexa App? I’m thinking Dojo may prompt you to allow the 'service' (not sure service is the correct word to use here) and once you accept it, it might then go onto work for you.