Question

Alexa skill setup; stuck in a loop

  • 12 September 2020
  • 7 replies
  • 152 views

I’m trying to setup the Alexa skill so I can control my Sonos speakers. When I’m doing this, I get stuck in a loop at the “Register your speakers” phase. I can see all the speakers when I sign into the website.

The only slightly complication I can see is that there are two systems in my Sonos account (both S1), one is at my office and one at home. I’m trying to setup the home system which has multiple ZonePlayers; the office one just has a single device which is switched off at the moment. 

I’ve submitted a diagnostic, number: 1709841000

 


7 replies

Userlevel 4
Badge +12

Hi @davep, sorry for the late response.

The speakers are showing on the website are mainly a record of the registration.

I checked the diagnostic, the diagnostic data is corrupted and unreadable.

Kindly check your other Sonos controller devices like a laptop with the Sonos App or a Mobile device with the Sonos  App; if they can connect to the system.

If you can’t connect to the system, try rebooting the Network system then reboot the Sonos speakers afterward.

Take another diagnostic, so we can check the Sonos system.

If you have other concerns, feel free to reach out.

@Kyle A Thanks for responding, and apologies it’s taken me a few days at get around to replying.

How odd; I’ve re-submitted the diagnostic information here having rebooted all the Sonos speakers - the ID is: 553567517

No problems with the apps on my laptop or phones connecting to the players; everything is working great apart from setting up the Alexa integration.

Dave

Userlevel 4
Badge +13

Hi @davep. Thank you for reaching back to us. 

Upon checking the diagnostic, all your Sonos speakers don't have a cloud connection. This means that your players don't have a connection to our Sonos cloud server.

Some of the features that may not work are:

  • Unable to use Voice Services like Amazon Alexa.
  • Unable to play from Spotify on Sonos or Direct Control from Spotify

To address this concern is to perform a sequential reboot of your network devices, all your Sonos products, and force close mobile controllers.

Sequential reboot means that we need to this in order.

  1. Unplug your network devices (modem, router, any wireless access points on the network) from the power and wait for 60 full seconds before you plug it back in.
  2. Once the router is back online, unplug all your Sonos devices from the power. Please wait 15 seconds before you plug back them back in.
  3. Force close the Sonos app from your iOs or Android device.
  4. When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.

Please submit a diagnostic for us to check your system if the error has been cleared. 

Also, I'd like to ask some questions to understand why you can't get past on registering your speakers on the Alexa app. Your Sonos products should be in the same network as your Alexa device to complete the setup.

  1. What type of Alexa product are you using?
  2. Do you use your Amazon account in another house or location?
  3. Have you tried to sign out from your Amazon accounts from your browser on your device controller?

If you need help with any other information, Please be sure to let us know.

 

Hi Rowena,

Thanks for your response.

I have followed the sequential reboot instructions above; but I’m afraid the problem persists. I get exactly the same issue getting stuck in a loop being asked to add my speakers to my Sonos account.

I use TuneIn radio and Spotify with Sonos throughout the house daily without any issues; and Amazon Music / Sonos Radio both work fine - so I assume it’s not a problem with connectivity from the zone players to the internet?

I’ve also tried clearing the cookies in Safari on the phone I’m using to try and set this up, just incase that was an issue. This had the effect of singing me out of the Amazon account too.

The Alexa products I’m using are a generation 1 Echo and a generation 1 Echo Dot; both working fine with other integrations. There is a FireStick connected to my Amazon account that is in another house.

O’ve submitted another diagnostic; this failed the first time but succeeded the second: 1411315655

I hope that helps; let me know if I can provide any further details.

Dave

 

Userlevel 4
Badge +13

Hi @davep. Thank you for getting back to us on this and for submitting the diagnostic report. I really appreciate all the troubleshooting you have performed so far in getting this concern resolved.

Upon checking the diagnostic, I'm still seeing the same results, all your Sonos speakers don't have a cloud connection. Your Sonos products should be in the same network as your Amazon Echo Dot to work.

This usually caused by network communication, either between Sonos devices and your router or between Sonos and the internet. Normally, this can be resolved by performing the sequential reboot which you have already done.

To further assist you with your concern and to provide you the best option on this, I recommend contacting our Sonos Customer Care.

We're here to answer any further questions you have. You're always welcome here in the Community.

Thanks; I’ll raise a ticket. 

Userlevel 4
Badge +13

Hi @davep, thank you for your response. 

Please feel free to reach out in the future if you have any other questions.

You're always welcome here in the community.

Reply