Answered

Alexa only plays one song and then stops

  • 5 January 2018
  • 15 replies
  • 7999 views

Hi Folks



Happy New Year to everyone!



Just bought my 3rd Sonos this week (Sonos One). Alexa is only playing one song on a playlist then stopping which is driving me insane.

Has anyone got a solution to this very annoying problem please?

Looking at the forum it seems like a very common problem that keeps lingering on which is very disappointing considering the reputation of 2 huge companies Amazon & Sonos.



Any help or advice from anyone would be much appreciated?



Thanks
icon

Best answer by Ryan S 6 January 2018, 00:17

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Userlevel 7
Badge +20
I was frustrated with the problem on setting up my first Sonos products today. For me the fix was to remove Amazon as a music service from within the Sonos App. Now voice commands work perfectly, playlists, radio and album change track correctly. I can't use the Sonos App to select music from Amazon Music but that doesn't bother me.



This isn't required for voice control to work. Did you set up a default music service in Alexa App>Settings>Music & Media? The Answer in this post details steps to sort out most issues relating to Alexa playback issues:



https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-she-is-playing-on-kitchen-but-no-sound-comes-out-6800126/index1.html#post16201009
I was frustrated with the problem on setting up my first Sonos products today. For me the fix was to remove Amazon as a music service from within the Sonos App. Now voice commands work perfectly, playlists, radio and album change track correctly. I can't use the Sonos App to select music from Amazon Music but that doesn't bother me.
Userlevel 1
Thanks Ryan S ....... appears to be working again now
Got mine on Christmas Day. It worked that day nad the 26th. By the 27th it could only stream one song then quit.
Userlevel 7
Badge +26
There was an outage on the Alexa on Sonos connection that's since been resolved. You should be back up and good now.
Mine is working again now. Thought i would try it again and the skill logged in this time and linked. I have to set up my groups again but other than that it seems to work so far. It has played more than one song anyway.
Double post, sorry.
I had the same problem when I originally linked Alexa and Sonos, one song would play, and then I lost all control of the device from there. I was able to fix it by disabling the linkage and re-enabling. Worked flawlessly for months now. About 30 minutes ago, the exact same issue started happening. I performed the same task, and now I get an error message saying "An error occurred while attempting to link Alexa with Sonos. Please try again later."



I have tried from two phones and my computer, and no luck. I agree there has been a significant increase in similar traffic on the web in the last half hour. It makes me think Amazon or Sonos are having a problem.
Makes me glad I've held onto my Slacker account until I can navigate all my stuff (favorites) over to Amazon Music as I just noticed this today after having enabled the Sonos skill on Alexa and removing the line-in from my 5... hope it's figured out soon for us all 🙂
Userlevel 1
Been there for a few months I think Rich N.....I just mailed Amazon about it as well
Badge
There seems to be a flurry of posts about this issue over the last 20 mins or so. I guess a fault has developed somewhere with Alexa or Sonos.
Badge
I had the same issue earlier, I disabled the Skill and now I can't re-enable it! Bloody frustrating!
Userlevel 1
Me too....used to work fine but has been doing the one song thing for a while......I saw elsewhere on the forum from a few months ago the thing about disabling the skill and forgetting the devices but I fear the same problem that kdewsnap had.......also, on the same thread from 2 months ago someone from Sonos said they were looking in to it......surely Sonos/Amazon you should have resolved this by now?
We have the same issue, just tried to follow a guide from an older post saying disable the skill and forget devices then start them again and i can’t i disabled the skill but it won’t enable again now so cannot control my speakers at all now!!
I started having this same issue today. Any help is appreciated.