Answered

Alexa - one way speaker control

  • 10 January 2019
  • 8 replies
  • 87 views

Very new sonos owner here. I've read through the topics on here and can't an answer.

I have two sonos one's - one in the kitchen and one in the living room. Both on the same wifi network. I can ask alexa on the living room speaker "play radio one in the kitchen" and it will work, but I can't ask from the kitchen, "alexa play radio one in the living room" - is this a bug? do I need to reset the network or the speakers?
icon

Best answer by melvimbe 10 January 2019, 20:34

Ok, then I' d try re-enabling the Sonos skill.
View original

8 replies

Userlevel 7
Badge +21
You should be able to do that. Do you have anything else setup in Alexa with the name 'living room'? If so rename one of them. Disabling and re-enabling the Sonos skill might resolve the issue as well.
Thankyou Melvimbe. I have nothing else in the living room, but occasionally kitchen sonos will tell me "living room is offline" even though it isn't, and is visible as active in the sonos app.
Userlevel 7
Badge +21
Ok, then I' d try re-enabling the Sonos skill.
Ok so,
I disabled and reenabled the sonos skill.
Now when I say "alexa, play radio one" I'll get the response "playing radio 1 from tunein. Sorry but that device is offline"

I can still play stuff to both speakers together or separately via the Sonos app, but not via Alexa.
Userlevel 7
Badge +20
Ok so,
I disabled and reenabled the sonos skill.
Now when I say "alexa, play radio one" I'll get the response "playing radio 1 from tunein. Sorry but that device is offline"

I can still play stuff to both speakers together or separately via the Sonos app, but not via Alexa.


Normally powering the device off for 5 secs and then back on again will fix this.
Ok so,
I disabled and reenabled the sonos skill.
Now when I say "alexa, play radio one" I'll get the response "playing radio 1 from tunein. Sorry but that device is offline"

I can still play stuff to both speakers together or separately via the Sonos app, but not via Alexa.


Normally powering the device off for 5 secs and then back on again will fix this.


This did not work. Powered off both devices, left for a few mins and turned back on again, no joy.

Alexa will still respond to things like "whats the time" etc but nothing to do with services. Eg: "listening to X from spotify, sorry the device is offline" etc.
Userlevel 7
Badge +20
If you open the Alexa App>Settings>device does it show the Sonos One's as Off-Line? Can you have a look at these steps:

Sorry for the long post:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Ok, this seems to have been the solution for me:

3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen


3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa browser app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.


Both Sonos' are working correctly now.

Thankyou to everyone for your input!

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings