Answered

Alexa is not working on Sonos One

  • 4 January 2018
  • 29 replies
  • 96539 views

Userlevel 1
  • Contributor I
  • 0 replies
I set up the Sonos One two weeks ago and it connected fine to our existing Sonos system. Alexa voice was also working well. The Sonos One was unplugged for several days, and when I started it back up, Alexa did not respond, It appears that the voice services in the Sonos and Alexa apps on my Android phone are active. The system plays music just fine via the Sonos app.

Any ideas on what might be wrong?

Thank you in advance...
SDK
icon

Best answer by UKMedia 5 January 2018, 10:39

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

29 replies

OK. After hours upon hours of resetting Donos and Alexa. No progress. Unplugged and decided to throw it out. 

THEN!!!! 
on a lark I decided to plug it in and try one more time. 
 

Plugged it in. Waited a few minutes and said “ Alexa! Can you hear me?”  SHE ANSWERED and said “Yes,  I hear you.”  Then, everything worked. 
 

Now, the only way to wake her is to say “ Alexa. Can you hear me”. 
 

Go figure. 

Long time Sonos and long time Alexa user here. First time I setup my Sonos One, it took hours to get Alexa + Spotify + Flash briefing working
 

Moderator edit: Removed spam link

Perhaps try ending the 'current session’ and also then clearing any room queue from within the Sonos One’s ‘now playing’ screen within the Sonos App and see if that maybe resolves it. If not, then have that glass of wine.🍷

I have disabled skills removed from Sonos and from Alexa app nothing work. Alexa responds and says she is playing the requested music on spotfiy and then keeps playing the same track.  Also she will not skip or stop playing music.  Totally frustrated have tried everything ☹️.  Please don’t suggest I have a glass of wine

I did try to turn it on (by pressing it) but it will stay on and it makes a "boing" sound and stays off.
Does the mic light stay, on if you give it a “quick tap”, rather than a “press”? ...if not, then goto the Sonos “Room Settings” for the speaker and toggle off/on the 'speaker touch controls' button option and then try again.
Badge
I did try to turn it on (by pressing it) but it will stay on and it makes a "boing" sound and stays off.
I disabled Alexa skill and re-enabled it .. now Alexa does not see the speakers, they are on the same wifi network, but nothing. Every time I press the speaker button the light is not staying on.

Now what?

It sounds like you may need to switch on the mic on the top of your speaker. Have you checked that it is enabled?
Badge
I disabled Alexa skill and re-enabled it .. now Alexa does not see the speakers, they are on the same wifi network, but nothing. Every time I press the speaker button the light is not staying on.

Now what?
bgoldie,

Good to hear you managed to sort it.
I figured out what was wrong. I had two Sonos "systems", one at my work, and one at home. Each had a different sonos login. When I added the Sonos skill to Alexa, I put in the wrong login and so it was connecting to the other Sonos system. All seems to be working now. What a nightmare though!! Thanks for the help, KG.
Bgoldie,

Go back to the Alexa App, smart-home "devices" and remove all the instances of your Alexa speaker (Room Name) and then ask alexa to rescan for devices. Then in the Sonos App 'room settings' for the speaker ensure the device is linked to your Amazon account.

Then try the alexa voice control again.
I'm having the same issue. Was working fine until I changed my network settings. Now my Sonos One works fine through spotify or Sonos apps, but won't play music via voice command. I disabled/re-enabled the Sonos skill in the Alexa app, and now it thinks the skill is no longer enabled (even though it is according to the Alexa app). Then I did a factory reset on the unit and re-installed. Still the same issue. I did not log-out and remove every Amazon owned app (I've got many phone, computers, tablets, and echo devices and that would be a nightmare). I submitted diagnostic report 868345569. Sonos staff, please help!!
Also have this issue, tried all suggestions with no progress. Submitted diagnostic #1690441196

Help please
Userlevel 7
Badge +20
I am having similar issues. I initially set up Sonos 1 fine, Alexa worked. Moved to new room and not working. I have checked device is in Alexa app. I have deleted and redownloaded Alexa and Sonos app. I have re-added the Sonos one to my account, I have checked the microphone at the top of the ONE. Nothing is working. when Sonos goes to the Alexa app to enable, it shoots over to the amazon app and then back to Sonos app asking to connect the Alexa app and does this over and over again.

Please try section 2 in the Answer to this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-she-is-playing-on-kitchen-but-no-sound-comes-out-6800126

Let us know how you get on.
I am having similar issues. I initially set up Sonos 1 fine, Alexa worked. Moved to new room and not working. I have checked device is in Alexa app. I have deleted and redownloaded Alexa and Sonos app. I have re-added the Sonos one to my account, I have checked the microphone at the top of the ONE. Nothing is working. when Sonos goes to the Alexa app to enable, it shoots over to the amazon app and then back to Sonos app asking to connect the Alexa app and does this over and over again.
Userlevel 7
Badge +20
Jeff,

All is well now. Working perfectly.

I mistook the center status button for the Mic button. I’ve got the unit in a bookshelf and it is difficult to see the complete top of the speaker.

Embarrassing for sure.???

Thanks again,

John


No worries, John. It's good to hear that things are working.
Userlevel 2
Badge +2
Jeff,

All is well now. Working perfectly.

I mistook the center status button for the Mic button. I’ve got the unit in a bookshelf and it is difficult to see the complete top of the speaker.

Embarrassing for sure.???

Thanks again,

John
Userlevel 7
Badge +20
Already tried that.

Diagnostic number is: 1723655757

Any input is appreciated.

John


Your diagnostic shows that the Sonos One's microphone is disabled. Do you see the small white light on top of the Sonos One near the microphone symbol? You can tap the microphone symbol to toggle the light on and off. With the light on, see if you can get the voice commands to respond.
Userlevel 2
Badge +2
Already tried that.

Diagnostic number is: 1723655757

Any input is appreciated.

John
Userlevel 7
Badge +20
Can't get Alexa to work on mine. Mic is on and disabled/enabled the Sonos skill. Still no Alexa.

How to send Sonos a diagnostic report to take a look at.

Acting like a Sonos Play:1. Can play music manually no problem.

John


Hi John,

Have you tried discovering devices again in the Alexa app? This may help Alexa find your Sonos One and get things working. If not, here's how to submit a diagnostic report. Reply here with the number and I'll take a look.
Userlevel 2
Badge +2
Can't get Alexa to work on mine. Mic is on and disabled/enabled the Sonos skill. Still no Alexa.

How to send Sonos a diagnostic report to take a look at.

Acting like a Sonos Play:1. Can play music manually no problem.

John
I read on a different thread to check the top of the Sonos unit and to tap the microphone to make sure that it is on (in the "arc of dots" on the top of the unit, there should be a lit up dot right across from the microphone; if you don't see it, tap the microphone icon on the top to turn the microphone back on). Lit up = ON. No dot showing = OFF. This worked for me! Easy fix.
Userlevel 7
Badge +22
You would say Alexa play music on living room”
Userlevel 7
Badge +20
I set up the Sonos One two weeks ago and it connected fine to our existing Sonos system. Alexa voice was also working well. The Sonos One was unplugged for several days, and when I started it back up, Alexa did not respond, It appears that the voice services in the Sonos and Alexa apps on my Android phone are active. The system plays music just fine via the Sonos app.

Any ideas on what might be wrong?

Thank you in advance...
SDK


Can you check that the small white round light is still showing on the top of the speaker? If not, you've turned the mic off by accident - just touch the mic symbol to turn back on.
Userlevel 7
Badge +20
To tag onto this issue..... I disabled sonos skill and re-enabled and that worked to some degree! Thanks Chris. So far only the Sonos One will work with a voice command. When I tell Alexa to "add living room" she doesn't know what I'm talking about. The various rooms do show up in the "smart home" section of the Alexa app because I did add them. They appear to be enabled and they do all work via the sonos app. I appreciate any help as I've worked on this for hours and hours.

It's not possible to group rooms via voice control at present, this needs to be done in the Sonos App. Then if you ask Alexa to play music to any speaker in the group, it will output to the entire group.