Question

Alexa fails to find new device.

  • 11 August 2020
  • 13 replies
  • 117 views

My wife is disabled and wanted to be able to control the curtains through our Sonos system. The curtain rail is installed and working using the remote control supplied and through the Alexa ‘Tuya Smart’ skill which is linked and enabled. On the Alexa App, the curtain device is shown and can be controlled but our Sonos speakers simply says ‘ Sorry, I didn’t find a device named curtain.’

My wife cannot handle the remote control or manage a smart phone or tablet which is why we opted for voice control through Alexa.

Please help us.

Mike


13 replies

What is the exact phrase you’re using with Alexa, and does that exact same phrase work when you use a voice command on your phone through the Alexa app?  Is ‘curtain’ listed under devices in your Alexa app?

Using the Alexa App, I simply say “Open Curtain” or “Close Curtain” and it works. But if I ask one of my Sonos speakers to “Close Curtain” I get the “I couldn’t find a device named Curtain”

‘Curtain’ is listed as a device in the Alexa app and works from the app but my wife cannot control a mobile phone with sufficient dexterity.

What is the device type of ‘curtain’?  I imagine it’s specified as a ‘switch’, but wondering if it’s something else.  Sorry for all the questions, just trying to understand the situation a little better. I was hoping it was something as simple as not using the right voice command, but it doesn’t sound like it.

Hi Danny, thanks for your time.

The curtain rail is by Abalon and setting it up was pretty simple. The rail uses an app called Tuya Smart that is linked with the Alexa app and that all worked smoothly. It is just that the Sonos system does not pick up the linked device. It is listed in the Alexa app but not in the Sonos app.

Mike

Userlevel 1
Badge +2

Unlikely solution, but are you sure you are signed into the same Amazon Alexa Account on your Sonos system as you are on the Alexa app? This thread may offer some insight:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-on-sonos-1-stopped-finding-tuyasmart-plugs-6803006

It is possible to have different devices in a Sonos system connected to different Alexa Accounts so as suggested, you could try “Alexa switch user”.

To be sure, in the Sonos App go to Settings/Services & Voice/Amazon Alexa and look at the account name listed under each device.

  • SkiBuddy, I think you may have the solution there. When I checked on the Sonos app, my wife’s email address comes up for each of the speakers. So, the question now is how do I add myself as a user?

This is getting really confusing! My Sonos account is in my name but the speakers are all in my wife’s name. Can I just re-name each speaker?

Userlevel 1
Badge +2

When you created your Sonos account it was in your name, but when you linked an Alexa account to your Sonos device you used your wife’s Amazon Account rather than your own. Does this ring true?

In the Sonos App you will need to remove the Alexa Voice Service from the Sonos device and then re-add it. When you re-add it, make sure you use your own Alexa account details rather than your wife’s.

As an alternative, you could login to the Alexa App using your wife’s account, add the ‘Tuya Smart’ skill, logging into Tuya using whatever account it is you have already created with Tuya.

I am in a total mess now. The Sonos app was originally created in my wife’s name and since then, my wife’s health has deteriorated to the extent that I do most of the things that require finger dexterity i.e. keyboard stuff. We both have Sonos apps, both have Amazon accounts and both have Alexa apps. Knowing which goes where and is linked to what is just a nightmare. I have just tried deleting my wife’s account from the Sonos app and using my Sonos app to re-assign it. It now appears to be dead and the microphone will not light up.

How do I start from scratch!!!!????

Userlevel 1
Badge +2

Hi Mike, Sonos devices can only be assigned to one Sonos account. You can sign in to the Sonos account from the Sonos App on multiple devices, which is what it sounds like you have done. You then add a Voice Service to each of the devices registered with the Sonos account, in this case Alexa as apposed to Google home. I suggest you remove the Alex Voice Service through the Sonos app from each device and also remove/dissable the Sonos Skill from within the Alexa App. This should allow you to start again.

Thanks for that. I will attempt to do that later on as it will take me some time to sort it all out and I will report back. Thank you for your time and advice so far - it may well have to continue!!

All sorted!!!  My wife can now open her curtains with her voice. Many, many thanks for all the help. These forums are brilliant!

All the very best,

Mike

Glad you got it resolved.  Never thought about the possibility of mixed accounts.

Reply