Answered

Alexa controls

  • 17 October 2017
  • 2 replies
  • 159 views

I have 6 Sonos players and 2 Echo Dots. I’m having trouble controlling Sonos. If I ask Alexa to play music in a specific room, it plays music in all rooms. It doesn’t matter which room I say, it plays in all rooms. I’ve tried to disable the skill and forget the Sonos devices and then re-add the skill and the devices, but it didn’t help.
icon

Best answer by jgatie 17 October 2017, 05:21

If the rooms are grouped via the Sonos app. all rooms in the group will play when you tell it to play on one. Ungroup the rooms in the Sonos app to solve. If your rooms are not grouped, send a diagnostic and post the number here.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

If the rooms are grouped via the Sonos app. all rooms in the group will play when you tell it to play on one. Ungroup the rooms in the Sonos app to solve. If your rooms are not grouped, send a diagnostic and post the number here.
Currently, when you use the alarm function in the Sonos native app and only sound the alarm on Speaker A (not selecting the "use grouped speakers" option), it un-groups all the speakers that were previously grouped with Speaker A. I mention this because I have some night-time rules with SmartThings that I want to only send notifications to Speaker A (in my bedroom), such as when my 2 year old's door opens. I set up is a nightly 12:00 alarm with Sonos on Speaker A (set to volume 0 and stops after the minimum 5 minutes) - I know that after midnight all my speakers are now un-grouped for the night. There will be an alarm notification to clear on your phone every night.

Just an FYI for those who have certain times in which they want to make sure the speakers get un-grouped - I would be interested to know if there is a better solution since this may not work forever.