Answered

Alexa asking to link Spotify Premium Account even though already linked when using Sonos

  • 15 November 2018
  • 40 replies
  • 7895 views

Having an issue where whenever I try to play something on Spotify on Sonos using Alexa, it's just coming up with 'To link your Spotify, please add a premium account in the Alexa app' even though I have already done this.



When I try to play Spotify using just the Echo dot it's playing fine - just doing this when I want it to play on the Sonos!



Anyone have any ideas?



Thank you 🙂
icon

Best answer by Jeff S 16 November 2018, 00:47

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

40 replies

I spoke to Sonos support and they indicated that there was an outage affecting our ability to play Spotify directly via a Sonos device.
Userlevel 7
Badge +20
Hi folks,



We're working to resolve an outage right now affecting Spotify playback via Alexa on Sonos. We'll update this thread when the outage is resolved.
Userlevel 7
Badge +20
I've been having this issue yesterday and again today when trying to set up my new Sonos One. I can play Spotify through my Sonos One from the Spotify app but have the same issue as the OP when I try to play Spotify using Alexa.



Please find below my standard trouble shooting guide for Alexa problems on Sonos, they get more complex as you progress:



1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,

1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;

1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)

1.3/ Once you have changed any duplicate names then please open the Alexa App on a web browser(https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the browser version has this functionality.)



2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:

2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';

2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;

2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'



3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:

3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';

3.2 In the Alexa app (browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;

3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';

3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;

3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;

3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;

3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';

3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.

3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.
I spoke to Sonos support and they indicated that there was an outage of some sort affecting our ability to play Spotify directly via a Sonos device (as indicated by others, it works when you play Spotify off of another device's Spotify application - just not via Alexa voice control). They did not know when it would be fixed.
Userlevel 7
Badge +20
Hi everyone,



The outage affecting Spotify playback through Alexa on Sonos should now be resolved. Please submit a diagnostic report and reply with the confirmation number if any issues continue.
Userlevel 7
Badge +20
I'm having this issue and can't seem to resolve it using many of the steps provided by others. My confirmation number is 173648517



There was an outage on Spotify yesterday. Can you please retest and post on this thread if the issue persists?
Userlevel 1
Badge
Not sure if this helps at all but I just recently had this problem few days ago and fixed it just maybe yesterday I wasn't able to play music on my Sonos from the Spotify app on my phone but I could on my tablet and while trying to troubleshoot I opened up the Sonos app on my phone which I knew would play already and went into my settings to check for online updates and it was one of vailable after the update finished I closed it out went back into the Spotify app and was able to select the Sonos and now my music is playing. Hope this helps
Userlevel 1
Sounds like we're experiencing the same issue: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-spotify-needs-to-be-linked-but-it-is-already-linked-6815395
I have the same issue. Sonos One was playing Spotify perfectly until this morning and now I'm getting the response 'to play Spotify, first link your premium account using the Alexa app'. Help!
Having the same issue, just as of this morning. Worked last night, and nothing changed. Tried to re-register and re-everything.
I have the same issue. Sonos One was playing Spotify perfectly until this morning and now I'm getting the response 'to play Spotify, first link your premium account using the Alexa app'. Help!
Userlevel 2
Same issue for me. I can use Spotify through the Sonos app, but as soon as I ask Alexa to play something I get the link your premium account message. Seems a Sonos issue though, as when I try it with my Echo Dot, it still works.
I have the same problem, and my system was previously working.

I have a premium Spotify account which is linked in the Alexa app and Alexa will play spotify on it's internal speaker on command (echo) without any problems.

When I say "play Spotify on " then Alexa says "To play Spotify, link your premium account first using the Alexa app." The app is definitely linked as it works on the echo directly.

Alexa commands to play TuneIn Radio also work so when I say "play Radio 1 on " this works straight away implying the link between Alexa and Sonos is working.

I can start Spotify playing through the Sonos app and through the Spotify app too. When I ask Alexa a question while this music is playing she also partially mutes the volume on the Sonos to hear the command. Alexa will also stop Spotify playing with a simple "Alexa - Stop music" command.

This leads me to believe that this is some sort of Spotify authorisation issue to do with Alexa but for the life of me I can't work it out. Has anyone had any experience with how Spotify authorisation works?



I have also tried:

Forgetting all devices and re-discovering in Alexa App

Unlinking and re linking the Spotify Account in Alexa app and Sonos

Disabling sonos and spotify skills and re enabling in Alexa app

All of the above with a full power down of Alexa devices

Logging out all devices from the spotify web account and re-linking.



It's like Alexa is not recognising that it is a Premium Account.
Having the exact same issue here. This has always worked, but this morning I am getting the same response "To play Spotify, link your premium account first using the Alexa app."



It does appear to be an issue only with Sonos. When I ask a Echo or Dot to play Spotify, it works.



Hopefully, Sonos can figure this out quickly.
To Sonos engineers:

Can you tell us how Alexa is able to validate the Spotify account when passing it to it's own speakers but seems to not function if passing it to a sonos speaker?
There might be a system or server failure on the Amazon/Sonos IT Cloud of things.
Same issue as of today. Been working perfectly up until now.
Thanks jmckeand - Did they suggest any solution to the problem?
Badge
Just picked up 2 Sonos Ones.



Several hours of frustration with the Ones vanishing from Spotify Connect for no reason, and adamant they wouldn't come back, and now the same issue as OP. If I ask Alexa to play music, it defaults too Amazon Music, despite Spotify being default service (and acts as such on my Echo). When I state 'play x on Spotify', I get the link premium account to Alexa app.' Which it is.



For what it's worth, Amazon Echo is quite happily playing music via Spotify.



At this point, I am not quite sure I will need the remaining 99 days of the listening trial.
Badge
"They did not know when it would be fixed."



Sonos's default answer to most things it seems.
Userlevel 2
Badge +3
Same issue here, even reset my Sonos One to factory settings and wiped Alexa from the device, relinked Spotify, etc. Suppose it wouldn't hurt to have read the forum first 🙂
Badge
I have the same issue. Thanks for setting up this thread, I’ll just give it some time to be fixed then, instead of wasting any more time resetting everything 🆒
Badge
Does Sonos have a server status page like Apple etc, so we can check of any issues?
Same issue as of today and not able to resolve. With the outage did they say when it would be resolved or how to resolve?
+1 for a live traffic light style service status page