Zone Player Drops From Network

  • 3 September 2017
  • 1 reply

I have dedicated a lot of my time trying to troubleshoot my Sonos set up. What I have discovered (I think) is that the Zone Player will frequently drop off of the network - which effectively kills the system. Right now, I am using a ZoneBridge (BR100) Wireless Bridge but that hasn't always been the case...

* I am using a Verizon FIOS ActionTec (MI424WR-GEN3I) router with wifi disabled.
* It statically assigns IPs by MAC for all of my major components on the network (Unifi APs, NAS, FireTV, AppleTV, ipads, iphones, pcs, tvs, XBox, printers, etc.).
* I also statically assign IPs for the Sonos components which include PlayBar, Play3s, Play1s, ConnectAmps).
* I have two access points (UniFi Enterprise AP) which deliver the wireless service to my home.

At first I tried to use my own wireless network and the PlayBar as the ZonePlayer. Sometimes this set up worked great but unfortunately an AP set up really confuses the heck out of Sonos. The problem was that controllers would only see components on the same AP (iPhones, PCs (win10), & iPads all had the same problem). Sonos support never gave me a good reason why this is the case, but I can confirm, having tried this configuration for ~1 year that Sonos has problems with an AP setup. That said, I don't think this is my root problem because I would routinely see the ZP dropped from the network even when the host device, like PlayBar, was accessible.

My second attempt involved dusting off my Sonos Bridge and using that as the ZP. This also worked OKuntil the ZonePlayer drops its connection with the router - even though it is physically attached to the router and has a static IP assigned to it - the ZP drops off. Nothing else on my network has trouble staying on the network...and nothing I have done has permanently resolved the issue. What I see, frequently, from the router address distribution page is that the ZP for sonos has an expired IP. Sometimes rebooting the router works, sometimes it doesn't. Sometimes rebooting the ZP works, something it doesn't. Sometimes rebooting the entire sonos mesh (all boxes off and reloaded) works and sometime times it doesn't.

Any help would be really appreciated. I just submitted a diagnostic (7798827).


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

I had a very similar problem with my ZP (or Connect) and it frustrated me very much over many months and many calls to Sonos Support. My ZP was wired directly to my router, but they were located in the same cabinet so I suspect that there was interference between the two. The solution I found was to disable the wifi on the ZP as in the following link:

after which the ZP has worked perfectly. Of course, the wired ZP no longer has a wifi output, so I used a Boost (you could use the Bridge) also wired directly to the router to provide my other Sonos products with their wifi signal. I suspect that the output of a ZP can be affected by wifi interference, but that the Boost does not have the same issues. I have reported all of this to the very helpful Sonos Support people and they had no issue with me disabling the ZP wifi. Of course, if this doesn't fix the problem in your case then you can always just enable the wifi on the ZP again. Good luck.