Sonos won't forget WiFi network, won't let me change to different one

  • 19 August 2017
  • 1 reply
  • 1123 views

Hoping someone can help with this as it has become very frustrating.

My sonos, for whatever reason, wants to connect to my guest network (which has a password prompt at a login page). I'd prefer it to use my non-guest network (2.5 GHz b/g) so I can just provide the password directly in the setup. Whenever I go to advanced settings --> wireless setup it shows that "Sonos will be set up on: mynetwork-guest". I click "Use another network". In the net screen I am allowed to select a new network, so I select "mynetwork" (which appears in the list, and is the network I WANT to use). When I select it and hit "Use this Network" the next screen still says "Sonos will be set up on mynetwork-guest". It seems to not recognize at all that i'm changing the network. It does this no matter what network I choose.

Why is this important? Because since I can't provide sonos with the network password (given it forces you to a login page), Sonos never actually connects to the wifi network. And so if I want it available on my network, I need to keep it hard-wired into the modem :/

Anyone have any ideas?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +21
The nuclear option is to factory reset the Sonos. Not a problem if you have no favourites, services or Sonos playlists created as these will be wiped.

If that is not an option can you perhaps disable to guest network temporarily?