One speaker from stereo pair stops working



Show first post

161 replies

Badge
Can anyone let me know what my diagnostics report above said please??
Only Sonos employees can see the diagnostics. You could either call in, or try their support on Twitter or Facebook, or wait here. I would think that on a Tuesday, someone here in the forums would be around fairly soon, I expect Mondays are fairly busy from catching up on the weekend posts.
Userlevel 7
Badge +20
I have the same issue - two play 1's - the right hand side one often doesn't play. Diagnostic report 1256881205 - can you help? Thanks

Hi there,

I see some wireless communication errors between your Sonos components. This may explain the issue with your stereo pair. Please try changing the wireless channel your system is using and see if that helps.
Badge
Hello, thanks for your reply.

So, since then, I've connected both of the stereo pair (Lounge 2) speakers to the router via Ethernet, and disabled WiFi on them, but the problem is still occurring, both when on TV and when playing music.

As before, if I ungroup the rooms and regroup them, the right speaker will come on again, but it will drop off again next time.

I don't understand why this would be, when they're on a wired connection now and not using WiFi.

My router is a Hyperoptic and is fine for everything else.

New diagnosics number is while music is playing and the right speaker isn't working: 361333548

Could you let me know what's going on here please? Thanks, M
Userlevel 7
Badge +20
I am having the exact same issue. I have two Play 1 pairs (plus two singles) and both pairs keep separating. The fix above works, un-pair then re-pair but this is annoying to do each day.

Diagnostics number is 1242515697.

My problem only started with the latest system update.

I have set fixed IP addresses and changed the wi fi channel, with no success.


Thanks for the report. Your Sonos speakers are losing connection from time to time with your wireless network. This can make it hard for your stereo pair to stay in sync. Please try changing your router's wireless channel to 6 or 11 and test things out again.
Userlevel 7
Badge +21
Won't hurt anything to set static/reserved IP addresses for your Sonos devices from your router's DHCP page, power down Sonos, reboot router, power up a wired Sonos and then your other Sonos stuff at minute intervals. Might help, might not, won't hurt.
Userlevel 7
Badge +20
I am having the same problem. Here is diagnostic # 388320624 Thanks.

In your report I see that there is some wireless interference making it hard for your Sonos speakers to keep in sync. This is probably due to your guest network, which is running on the same wireless channel as your main network, which can cause interference. Try changing your guest network's wireless channel to 6 or 11 and see if that helps.
Userlevel 7
Badge +20
Hello, thanks for your reply.

So, since then, I've connected both of the stereo pair (Lounge 2) speakers to the router via Ethernet, and disabled WiFi on them, but the problem is still occurring, both when on TV and when playing music.

As before, if I ungroup the rooms and regroup them, the right speaker will come on again, but it will drop off again next time.

I don't understand why this would be, when they're on a wired connection now and not using WiFi.

My router is a Hyperoptic and is fine for everything else.

New diagnosics number is while music is playing and the right speaker isn't working: 361333548

Could you let me know what's going on here please? Thanks, M


Thanks for trying that. I see some interference on the 5 ghz spectrum which would only affect your rear speakers and Sub. Take a look around those for any electronics which could be interfering with the 5 ghz signal.

For your stereo pair, I see that the errors are with the connection to your Mac. Is your Mac going to sleep while you are playing from it? Please check the computer's sleep settings in the energy settings page of the Mac's system preferences. Make sure it is set to never go to sleep and to not put the hard drive to sleep.

If these steps don't help, it would be best to continue troubleshooting this live with our phone team. You can find our phone number and hours here.
Badge
Thanks for the reply. I don't think it's anything to do with my Mac as this problem occurs whatever the audio source, including Amazon Music, or TV, which has nothing to do with my Mac.

There's no problem with the sub or the rear speakers so wifi interference is not an issue, and the problem is only ever with the right speaker of the stereo-pair, both of which are now hard-wired, so I can't understand why that would be.

Even when I swapped those two speakers round and re-paired them, the problem still occurs with whatever speaker is designated as the Right speaker, so it's not a fault with the unit itself.

I've tried tackling this with Sonos via Twitter but they just keep asking me endless irrelevant questions about my router and wi-fi extenders etc so I don't think I'm going to get very far there....
Userlevel 7
Badge +20
Same issue here. Diagnostics sent, #947515115. Thanks

Thanks for the report. I don't see a stereo pair in your diagnostic, and overall your system looks pretty good. I think Ken's advice to give us a call is good. Our phone team can help troubleshoot this with you live.
Userlevel 7
Badge +20
Thanks for the reply. I don't think it's anything to do with my Mac as this problem occurs whatever the audio source, including Amazon Music, or TV, which has nothing to do with my Mac.

There's no problem with the sub or the rear speakers so wifi interference is not an issue, and the problem is only ever with the right speaker of the stereo-pair, both of which are now hard-wired, so I can't understand why that would be.

Even when I swapped those two speakers round and re-paired them, the problem still occurs with whatever speaker is designated as the Right speaker, so it's not a fault with the unit itself.

I've tried tackling this with Sonos via Twitter but they just keep asking me endless irrelevant questions about my router and wi-fi extenders etc so I don't think I'm going to get very far there....


In this case it would be best to have our phone team take a deeper look. They have more tools available than our online teams. Please give us a call, our phone number can be found here.

Guess what. When I unpaired the pair they work perfectly fine anywhere in the house!. So the issue is a software issue with paired speakers. Can someone from tech support please respond?

Thanks for the reply. I don't think it's anything to do with my Mac as this problem occurs whatever the audio source, including Amazon Music, or TV, which has nothing to do with my Mac.

There's no problem with the sub or the rear speakers so wifi interference is not an issue, and the problem is only ever with the right speaker of the stereo-pair, both of which are now hard-wired, so I can't understand why that would be.

Even when I swapped those two speakers round and re-paired them, the problem still occurs with whatever speaker is designated as the Right speaker, so it's not a fault with the unit itself.

I've tried tackling this with Sonos via Twitter but they just keep asking me endless irrelevant questions about my router and wi-fi extenders etc so I don't think I'm going to get very far there....
Are you maybe running your devices in mixed mode? .. perhaps ensure that your WiFi credentials are not stored in the Sonos app 'Advanced Settings/Wireless Setup'... I don’t understand why you chose WiFi channel 6 either? Did you do a scan of the channels in use nearby using wifiinfoview (or similar software) to discover the least-used channel for your router? Also you will need to set your SonosNet channel to a completely different channel to the one in use by your router... Set that SonosNet channel at least 5 channels apart from your routers WiFi channel to avoid overlap of the signal.. it’s not just all simply about wiring your speakers, as the signal still needs to get through uninterrupted.
Userlevel 7
Badge +17
I believe it is the left speaker that does all the lifting, and passes right channel only to the stereo paired partner, keeping them in sycn etc. So check what electronics are between the two. Mine are on bedside cabinets with a wireless phone and clock radio between them. This is the only problem I ever have, and then it's only every 6months...so far....I wonder if updates kicks it off....
Badge
Thanks Paul. Would that happen though if both speakers are ethernet-wired to the router though? They are, so there's no wifi communication between the two speakers, so I don't understand why the right speaker would lose its connection...?
Badge
Thanks Ken, I chose channel 6 because Sonos can only use channels 1, 6 or 11, apparently.

I have since set SonosNet to Ch11 and my router to Ch4.

In any case, the speakers are ethernet-wired now, so the wifi channel is irrelevant, isn't it? I'm on a Mac, so if you can recommend a way of checking signals etc, that'd be good. Thanks.
Thanks Ken, I chose channel 6 because Sonos can only use channels 1, 6 or 11, apparently.

I have since set SonosNet to Ch11 and my router to Ch4.

In any case, the speakers are ethernet-wired now, so the wifi channel is irrelevant, isn't it? I'm on a Mac, so if you can recommend a way of checking signals etc, that'd be good. Thanks.
Cabling of the Speakers may not be relevant if the audio source is travelling over your local WiFi, for example an audio source on your MAC PC If that device was connected over WiFi for example. Also remember that your local network (wired & wireless) carries other network traffic so sometimes you can be far better off on SonosNet instead, as that is an exclusive wireless network for Sonos devices only.

To scan your locality for best wireless channel, use some software off the internet ... just google WiFi channel scanners. I tend to use either wifiinfoview but there are other scanners, InSSIDer being another. The reason Sonos chose just three channels 1, 6 and 11 is because those do not overlap and so having your router on Channel 1 and SonosNet on channel 6 or 11 would be better, but scan your locality first to find which of those channels are least used by your neighbours.

Then don’t forget the other things the Staff mentioned to you earlier and that’s to move things a couple of feet apart to reduce any interference around all your devices and hopefully all these things will then resolve your dropout issue.

Hope that helps.?
MattyBur,

See if this link also helps..

https://www.netspotapp.com/best-wifi-channel-scanner-apps-mac.html
Badge
Thanks for the advice, all.

Just to clarify, my Mac is hard-wired to the router by ethernet too (it's a desktop Mac Pro), as is the TV, so, since hard-wiring the Sonos speakers too, wifi shouldn't be playing a part in this at all. I only use wifi for my phone at home, really.

Anyway, I'll see how it goes and report back... Thanks again. M
Hi folks,

The majority of the time when one speaker in a stereo pair stops playing it is due to a wireless communication error between the sides of the pair. Please submit a diagnostic report after this happens, then reply here with the confirmation number.


Jeff, here is my diagnostic code. Same problem! 1233036126
Userlevel 7
Badge +20
Our two Sonos is on the same wifi.
Here is the diagnostic ID: 1836543787


Sorry for the late response. If you're still having issues, please try switching over all of your Ubiquiti access points to the same wireless channel. Channel 6 looks to be pretty good. When the access points run on different channels, it can make it hard for your Sonos speakers to stay in sync.
Userlevel 7
Badge +20
Hi folks,

The majority of the time when one speaker in a stereo pair stops playing it is due to a wireless communication error between the sides of the pair. Please submit a diagnostic report after this happens, then reply here with the confirmation number.


Jeff, here is my diagnostic code. Same problem! 1233036126


Thanks for the report. Your speakers are connecting to different wireless access points, which are running on different wireless channels. Please make sure all of your wireless access points are running on the same channel and see if that helps.
You could try setting a static/reserved IP address for your all Sonos gear using your router's DHCP page, that stops many odd things from happening.

Same problem here, but I'm using Boost so it's supposed that wireless problems are covered, so I don't know.-
No, in a BOOST or Wired setup, the devices would still be getting IP addresses from your router.
No, in a BOOST or Wired setup, the devices would still be getting IP addresses from your router.

Uhh, in that case, I'm gonna try fixed ips. Thanks Airgetlam!

Reply