Not quite flawless...

  • 29 January 2017
  • 6 replies
  • 359 views

First off, I LOVE SONOS! I've had the system for 3 years now. Been experiencing some issues lately and in reading threads in the community, I've become a bit over loaded with tech speak/potential issues with my system...so...thought I'd toss this out to the community and see if I can streamline the education/approach to my issues.

Our system consists of:

2 Play 5's, 4 Play 3's, 3 Play 1's, a Sound Bar and a Sub
Verizon Router and 2 WAP's

Our router is located in our detached garage and we have two WAP's in the house. In the middle of the house sits our Sound Bar, Sub and WAP #1. WAP#1 is 2' from the sub and Sound Bar and it is Ethernet connected to the sub. There are 3 Sonos speakers east of WAP #1 and 2 between WAP #1 and WAP #2 with a third speaker, a Play3 Ethernet connected to it. (They sit side by side, virtually touching). WAP #2 sits 40' west of WAP #1. I use our Play5's outside in the backyard around our fire pit as well as on our deck. The deck is nearest to the router, but new WAP is equidistant from the router while on the pool deck. The fire pit is my furthest point of speaker application from the router or either WAP. WAP #2 is new to the system and sits 40' closer to the fire pit.

I'm having fewer problems now, but it's still not perfect. My issues are primarily with connecting the P5's...I store them when not in use and pull them out and plug them in when I want to use them. 50/50 whether they'll join the network and be accessible on the controller. Is this because they don't 'live' on the network and pop in every now and then? My P5's are the only speakers I tend to move around, so I wonder if it's an IP assignment issue? I think I understand the IP issues, but the discussion of duplicate IP's has me confused. I'm also a bit turned around when it comes to the SSID vs channel # vs subnet something or other...

Our fiber optic cable was cut a few days ago, repaired and a new router installed along with a new WAP added at the same time...all three devices now have different SSID's and Password's...ISP Provider tech (a friend of mine) is coming by tomorrow to change the SSID'S and Network Keys. I had intended to have all three devices have the same SSID as well as the same Network Key (password?), but after reading numerous threads here, now I wonder what I should ask him to do for me!

Thanks to you smart folks in advance! I love my Sonos and want it to run flawlessly!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Thanks all! I'm slowly grinding this down! I have three projects going at once, so I haven't nailed this one down!
Userlevel 4
Badge +14
Given your setup, and the assumption that you are using SonosNet (because some Sonos players are wired) I'll give you the following advices:

Use the same SSID and passphrase on all your WAPs and the Wireless router. That way, devices will seamlessly roam between the different access points.

Configure all WAPs and the router to only use 20MHz channel width on the 2.4GHz band (150Mbit mode, or less. Your technician will know what we mean). Make sure that they are configured to use either channel 1, or 6 (preferably alternating them, so that the two closest WAPs/router doesn't use the same one).

Configure your Sonos system to use channel 11, since that is going to cover all over your house and you don't want your WiFi to interfer with the Sonos network.

the above channels are interchangeable, but the concept is to isolate Sonos on one channel, that isn't in use by your wireless network, also, 1, 6 and 11 are the only channels that do not overlap when using 20MHz channel width. You can read about it here: http://www.metageek.com/training/resources/why-channels-1-6-11.html

Assigning reserved IP-addresses is a good idea, but that is not the reason for your P5s to not appear when you power them on. They either doesn't get good enough wireless coverage from an adjacent Sonos player, or you have to much interference.

Also, to verify that all your players are using SonosNet, go to the Mac or Windows Sonos application, Help / About my Sonos system and verify that all your players in that list says "WM: 0". If some of them says WM:1, then you have a mixed setup which might cause all kinds of weird issues given your setup.

You could also clarify what make and model your WAPs are, and if they truly are, dumb access points (and not wireless routers). A lot of people don't know the distinction between them.
Badge +1
To log into the router you type the gateway address into the address bar of your browser where you would normally type the web address of a website you wanted.
In the example above the gateway is 192.168.1.1 but if that doesn't work yours may be different. Hope that helps.
Badge +1
You need to do this on your router. If your friend is coming over to set the SSIDs then he/she might already know how to do this. A quick Google search brought up the below for a Verizon router but as I don't know which exact router you have the below may not apply...


In the event you have a network device that you would always like it to have the same LAN IP address assigned to it, there is a way to do this in the Actiontec router. Although IP assignments are done dynamically, DHCP, there is a way to change the IP lease from dynamic to what the Actiontec calls a static lease. This is also commonly known as a "DHCP Reservation".

With a static lease, the Actiontec DHCP server allocates a pre-determined IP address based on a table with MAC address/IP address pairs. In this process, a "paired" IP & MAC address, is set to be assigned a static lease, instead of the default Dynamic. DHCP is still in effect, but it is just under more defined parameters.

The process to alter, the type of lease from Dynamic to Static on an individual MAC address is as follows:
1) Log in to your Actiontec router. at 192.168.1.1
1) Top menu bar, click on Advanced. Do you want to proceed - Click Yes.
2) Click IP Address Distribution
3) Click Connection List
4) You'll see a table "DHCP Connections", locate the device you want to change, and click (either) it's name in the left column, or the Edit icon to it's far right.
5) Your device will appear with a check box "Static Lease Type". Add a checkmark in that box.
6) Click Apply
7) Click close
😎 Logout
If you wish to revert from Static to Dynamic, just clear the checkbox in Step 5.


Hope that helps.
I have not tried that, not sure I know how to try that...
Badge +1
Have you tried assigning static IPs to your speakers? It's quite possible that they are joining whatever network has the strongest signal at the time and this may not always be the network you want them on. I have two routers and one of my speakers is wired to the router and provides a Sonos network for the others to join. I have no issues turning speakers off when not in use, they just connect back to the Sonos network every time.