Issue with Music library under Pref on a OSX


I'm trying to add my Music collection on a NAS that use a UNIX/OSX path in your software under preference - Music library, only to fail since all it see is a "windows path" and will not accept OSX path as per OSX setup. Please resolve this bad programing error.

3 replies

Badge +1
Almost any consumer or corporate NAS will use SMB for sharing. Your Mac's name for the directory is /Volumes/Music, but that's just the local mount name in OS/X - the NAS has an SMB path name as well. If you open a command prompt on your Mac and type "mount", you should get a list of mounted volumes, most of them local drives or USB drives. Look for one that looks like this: //NAME@NASNAME/Music on /Volumes/Music - where NAME is a username and NASNAME is the Windows name or IP address for the NAS. The SMB name for Sonos will be \\Nasname\Music.
Done as ya partly said and still can not connect to the NAS for there is no userid or password of this Shared folder for other apps to use but your app throws up an error (900)
Userlevel 1
Badge +1
Hello barnstorming92, welcome to the community. Can you provide us with the make and model of your NAS? We'll likely be able to assist you better once we know. Could you also show us the confirmation number from a diagnostic report so we can see what your Sonos sees? Here's how: https://sonos.custhelp.com/app/answers/detail/a_id/142

We usually suggest setting up a Sonos user on your NAS before adding a share, even if the permissions don't require it, just to prevent any user/login conflicts and/or conflicts with NAS security features. You may also want to see if the NetLogon service is enabled on your NAS, as that will cause it to throw error 900 if disabled.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)