Question

$2,500+ House System Connected Speakers Intermittently Show in my Sonos controller

  • 23 January 2017
  • 12 replies
  • 604 views

So this is extremely annoying and I am extremely frustrated with the producr to date. I have had these device almost 2 years now for the most part, and have been having this issue the last year. So the issue is with the application or the speaker itself. About 4 months ago, I upgraded our home Wireless internet with a new router/modem repeaters, etc. i thought this was the issue with the connectivity. Apperently thats not the issue, because it is happening to date.

Here is the system:
Play 3 - Garage
PlayBar - Fam Room (Closest to router)
Sub - Fam Room (Closest to router)
Play 5 Gen 1 - Main Area (Furthest From Router)
Play 3 - Master Bedroom
Play 1 - Master Bath

Description:
So this occurs intermittently, there is no cause, pattern, or reason quite frankly. Most commonly it occurs in the fam room, and the main area. I live in a split level home. The speakers are all connected wirelessly and connect to a Bridge which is hardwired to the router. All of my speakers connect to this bridge. For some reason, once I launch the app, connected to wi-fi it will load up, and instead of displaying and queing all 5 rooms, it will only show 1 or 2. Again no pattern, and it can occur on any of the 5 rooms at any given time. If I use the hard buttons, it will play music from my Google Play account, however still will not show in the sonos controller. I physically just wait it out and sometimes it kicks in, and other times it does not. I dont get it, I am extremely technical and have installed and manuafactured everything in house. Therefore I have already completed some troubleshooting.

Troubleshooting to date:
Reset room speakers and reconnected
Unplugged and plugged back in
Reset Sonos Controller and reconnected
Reset Sonos bridge
Pulled Bridge plug and plugged back in

Nothing seems to work and the only thing I have not tried is throwing everythig in the da** garbage, and using good ole bluetooth.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Since the PLAY:3 is already in the garage try wiring that to the router instead of the BRIDGE. Place it as far as possible from the router and security system unit.

If the BRIDGE power supply is on the blink this would remove it from the equation. Moreover BRIDGE only has SonosNet 1.0, which has a somewhat lower range than the SonosNet 2.0 supported by all the other components.
Userlevel 6
Badge +3
Hello perez.chris01

Welcome to the Sonos community

A few things you could try.

Next time it happens do a diagnostic and post the number here so a Sonos rep can pull your report and tell you what they see.

Connection problems which appear suddenly are often caused by network problems, not Sonos problems. The typical cause is duplicate IP addresses. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. Rebooting the router may correct this temporarily, but it actually exacerbates the problem because as soon as another IP lease expires, it starts handing out duplicates again. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem
Router
Switches or hubs
Wired Sonos units
Wireless Sonos units
Computers/printers
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.

Make sure your bridge is at least a meter from the router.

Make sure nothing is interfering with the signal. (like wireless phone, Baby monitor too close to the Bridge)

Make sure your SonoNet and router are on different channels.

https://sonos.custhelp.com/app/answers/detail/a_id/1230/kw/Sonosnet%20channel

Hope this helps.

Many user on here have rock solid systems and you can too!
Userlevel 6
Badge +3
How to submit a diagnostic code

https://sonos.custhelp.com/app/answers/detail/a_id/142/kw/diagnostic%20
Userlevel 6
Badge +3
To scan you home wifi environment:

http://www.howtogeek.com/197268/how-to-find-the-best-wi-fi-channel-for-your-router-on-any-operating-system/

With this test you can see what channel you and your neighbor are using and the best ones for you to use.
Hello,

Love this system, just hate these issues. The IP configuration does make sense. I will do a full system reboot, and also try assigning the IP addressing within the settings. I appreciate the information. Also, is their a specific frequency you see work better. 2.4Ghz or 5Ghz. The modem/router/bridge is in my garage along with the door opener. I also have an automatic security system, and If I am not mistaking this item's wireless transmission outlet is plugged in near the bridge as well. Would it be wise to seperate a bit more? As for Diagnostic, I have been doing these all day.
perez.chris01,

Since you are using a BRIDGE, SONOS will ignore your WiFi and WiFi will ignore SONOS, but SONOS will operate in the 2.4GHz WiFi band. It is recommended that you use channel 1, 6, or 11 for WiFi and a different channel for SONOS. Also, avoid using 40MHz channels. BTW: Your system is large enough that I don't recommend attempting to use the SONOS WiFi option rather than SonosNet. WiFi can work OK for a couple players, but WiFi is not robust enough for large SONOS systems.

The iPad/iPhone controller must have good WiFi coverage in locations where you want to use the controller. Androids can use WiFi or (optionally) SonosNet after first being setup using WiFi.

While working through this issue I recommend that you avoid factory resetting any of the SONOS units unless asked to do so by SONOS staff or a senior Community member. Factory Reset will not resolve this sort of issue and Factory Reset will destroy diagnostic data that could have been used to pinpoint the root cause.

If you can separate the router and BRIDGE by a couple feet or more, both WiFi and SonosNet will benefit.

Also, if you have a Voltmeter, check the BRIDGE power supply output. A healthy supply will put out about 5.1V. Low voltage can create intermittent issues that defy description.
I would just add please work with the good suggestions made, and if necessary work with Sonos Support and you WILL achieve the stable Sonos system that you desire.
Userlevel 6
Badge +3
After you run a diagonstic you need to post the number here for the rep to pull the report.
Hello All,

Thank you for your inputs. I think that I have figured it out, hopefully for good. I still have not been able to assign the IP addresses manually. I will figure this out soon especially if it occurs again. I will be working through implimenting a AP bridge to improve wireless reliability throughout the house.

I do have one question however. Will a Sonos Boost help signal reliability throughout the home for Sonos. As stated in description, my Play 5 is on the opposing side of my home, and the furthest away from the router/Bridge.
Hi. Using a BOOST instead of a Bridge wired to your router may help because the BOOST is more powerful. Once you have any Sonos component wired to your router, the SonosNet mesh network operates and each component is a potential repeater. Therefore if you have a speaker that is a long way from the router and from other speakers there can also be benefit in putting a Bridge or BOOST in between to relay the signal. You must keep a Sonos unit wired to your router for this to operate.
Userlevel 7
Badge +21
I still have not been able to assign the IP addresses manually. I will figure this out soon especially if it occurs again.
If you want to assign specific IP addresses to your Sonos devices, this is something you'll need to do on your router through DHCP reservations (sometimes also called Static DHCP), not the Sonos devices themselves. Most routers have a way to show a list of all the DHCP addresses in use... some will then let you click on an icon/button and create a reservation for that device. You can change the address if you want (for example, I have all of my Sonos devices with similar addresses, i.e. 192.168.0.15x), but as long as the address is reserved, your router won't give it out to anything else on your network.

If your router doesn't let you simplify by creating a reservation from an existing list of DHCP devices, the MAC address to use in creating the reservation is the serial number on the back or bottom of your Sonos device, without the last number. It should be 12 letters/numbers, six groups of two characters each.

And of course, once you do make this change, you should at least reboot your Sonos devices to make sure they pick up the new addresses, so you can make sure all is working properly. Otherwise, they'll pick them up when they try to renew their existing IP address with the router, and that could cause issues all over again.
Badge
I think that I have figured it out, hopefully for good. I still have not been able to assign the IP addresses manually.

If you need assistance with that, PM me. I am happy to help, or I bet most users here would be. I recently did it on my Comcast / Xfinity router with several devices to make sure they get the same IP consistently.